Saturn L Series Sedans & Wagons L100, L200, L300, LW200, and LW300

2003 Saturn L200

  #1  
Old 03-02-2010, 01:10 PM
Banned
Thread Starter
Join Date: Jul 2008
Location: United States
Posts: 11
Default 2003 Saturn L200

My daughter told me the a/c had stopped working. Initially I though that is was low on freeon, it's full. The compressor clicks on and stays on but the engines fans do not come on. I checked every fuse, they are all good. Swapped the relay for the horn relay wish is the same, no results. What else should I look at.
 
  #2  
Old 03-03-2010, 09:59 PM
Banned
Join Date: Jul 2008
Location: Riveria of America
Posts: 2,748
Default

No offense, but is the A/C "full" of freon because you found it that way, or did you add a can without checking the pressures? Possibility exists that the high pressure switch is open/bad, or even that the compressor has failed internally. Need to get some pressure readings posted before going further.......
 
  #3  
Old 02-01-2017, 10:38 AM
Banned
Join Date: Feb 2017
Posts: 3
Default

I had same problem and find out I had a leak in my hose so I replace the hose and it fit my leak. Went to auto part store and bought dye detection and follow direction and used a uv flash light and it show the leak. Try that . I only spent $23 on hose and put on my self
fix the problem. I do all the work on my saturn L200 2002. Hope this helps
 
  #4  
Old 02-05-2017, 08:39 AM
derf's Avatar
Super Moderator
Join Date: Jul 2005
Location: My Saturn ;)
Posts: 7,668
Default

Tidbits, PLEASE STOP NECROPOSTING to 7 year old threads. I know you are trying to help but this helps no one.
 
  #5  
Old 07-12-2018, 01:38 PM
Junior Member
Join Date: Jul 2018
Posts: 1
Default

Originally Posted by derf View Post
Tidbits, PLEASE STOP NECROPOSTING to 7 year old threads. I know you are trying to help but this helps no one.
Actually, it does help people who are still experiencing this same problem, like me. So, thank you to the "necroposters".
 
  #6  
Old 07-13-2018, 05:36 AM
derf's Avatar
Super Moderator
Join Date: Jul 2005
Location: My Saturn ;)
Posts: 7,668
Default

Multiple conditions can lead to the same symptoms, and the OP never ever replied.

Reading his post tells me he fixed something that may or may not had the same root cause. If he was chiming in his situation was IDENTICAL, fine. We'll never know since the OP vanished.

Nothing worse than trying to read through a thread packed with fuji, granny Smith, and red delicious apples. They're all apples but they don't taste the same as each other.

I don't get on people for necroposting info directly related to the exact situation someone else had.

Mixed apples don't cut it.

Thanks for reading
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kaushal402
Saturn L Series Sedans & Wagons
8
02-04-2017 09:44 PM
tim
Saturn L Series Sedans & Wagons
1
01-14-2012 10:11 AM
phxpilotmkv
Saturn L Series Sedans & Wagons
10
11-27-2010 07:40 AM
buddy5595
Saturn L Series Sedans & Wagons
0
08-02-2010 05:46 PM
stratman3
Saturn L Series Sedans & Wagons
4
11-27-2008 09:04 AM


Thread Tools
Search this Thread
Quick Reply: 2003 Saturn L200


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.