A/C Relay

  #1  
Old 06-13-2009, 09:30 PM
Junior Member
Thread Starter
Join Date: Jun 2009
Posts: 1
Default A/C Relay

I have a 2000 L300 (LS2).
The compressor is getting no voltage.
I ran 12 volts from the battery to the compressor and it worked fine.
I then removed the relay and jumped the relay. The compressor worked fine.
I then bought 2 new relays. No power with the relay plugged in.

What is it about the relay that I don't understand?
 
  #2  
Old 06-14-2009, 12:28 AM
Banned
Join Date: Jul 2008
Location: Riveria of America
Posts: 2,748
Default

There are safety switches in the relay circuit that prevent the compressor from running under certain conditions. They are:

1) No refrigerent in the lines (low pressure)
2) Compressor discharge pressure too high (no cooling to high pressure gas, or system improperly charged)
3) System thinks the engine is under very heavy load (passing gear, or pulling trailer uphill).
4) A/C switch is defective
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
vince1966
Saturn 3 Door Coupes
4
01-08-2009 04:16 PM
henryj10
Saturn S Series Sedan
4
11-19-2008 03:02 PM
7894steve
General Tech Help
10
11-12-2008 05:24 PM
saturn98
General Tech Help
1
08-09-2006 06:09 PM
NMattice
Saturn S Series Sedan
1
06-26-2006 10:33 PM


Thread Tools
Search this Thread
Quick Reply: A/C Relay


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.