Aura XR Turn Signal not working on front right - Not light bulb - Page 2 - Saturn Forum - Saturn Enthusiasts Forums


Reply
 
 
 
Thread Tools Search this Thread
  #11  
Old 02-20-2017, 09:41 AM
Junior Member
Thread Starter
 
Join Date: Feb 2017
Location: Michigan
Posts: 7
Default

I finally had a chance to take a look at the BCM after a crazy busy weekend. I got my blinker working too. The answer to my problem was simply unplugging the BCM connector and plugging it back in. Something must've just barley rattled loose over the years but it's back to working now! Thanks for all your help Derf. I would've never known to look for a BCM pinout if it wasn't for your help. Much appreciated.
Reply With Quote
  #12  
Old 02-20-2017, 11:44 PM
derf's Avatar
Super Moderator
 
Join Date: Jul 2005
Location: My Saturn ;)
Posts: 6,544
Default

Ah the loose connector/contact sweep.

Glad you're up and blinking.
Just goes to show that things that seem as though they may be horribly complicated often have simple solutions. And the simplest answer (once we got on target) was indeed the right one.

Don't be a stranger.....
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Sticky: R Front Turn signal & R Mirror lights not working 2010 Outlook lintg03 Saturn Outlook 3 05-31-2017 11:40 PM
right side turn signal donpaul Saturn Ion 3 07-30-2015 12:11 PM
turn signal and hazards not working turbozeke418 Saturn S Series Sedan 9 01-27-2009 08:57 PM
turn signal bulb murrietafx4 General Tech Help 4 01-28-2008 01:52 PM


Tags
aura, problem, signal, turn

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:52 PM.