Saturn 2009 Aura: ECT Sensor Location - Saturn Forum - Saturn Enthusiasts Forums


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-10-2017, 02:10 PM
Junior Member
Thread Starter
 
Join Date: Jun 2017
Posts: 2
Default Saturn 2009 Aura: ECT Sensor Location

Hi all, long time reader, first time poster, officially registered today.

Hopefully I can get relevant information as to the location of my electronic coolant temperature sensor on my engine block. I have poured through these forums for days now. None of the videos from Rich on Youtube or general location descriptions are matching up with my engine. And I think I have an idea where it is, but still not sure.

I just need to replace it really quick, but getting the information is turning out to be a bear. Can you help me?

I am unsure of my engine size. I just know that it is a 4 banger that runs like a 6.
Reply With Quote
  #2  
Old 06-10-2017, 09:09 PM
02 LW300's Avatar
Senior Member
 
Join Date: Apr 2015
Location: Willamette Valley, Oregon
Posts: 552
Default

Your car takes the same waterpump as my car. My temp sensor is on the back side of the engine near the brake booster. It is screwed into the water housing that both of my heater hoses come out of. It is between the heater hoses.
Reply With Quote
  #3  
Old 06-11-2017, 09:18 PM
derf's Avatar
Super Moderator
 
Join Date: Jul 2005
Location: My Saturn ;)
Posts: 6,544
Default

Seems to be a

TEMP SENSOR - GM (12608814)

Manufacturer: GM
Part Number: 12608814
Part: Temp Sensor

Visit

Temp Sensor - GM (12608814)

There are 3 pics there -- the rightmost one is a schematic that shows where it is (Item #12). It is right where 02 LW300 said it would be. Between the hoses.

Thought a pic would help
Reply With Quote
  #4  
Old 06-12-2017, 05:43 PM
Junior Member
Thread Starter
 
Join Date: Jun 2017
Posts: 2
Default

Thank you all for your help.

Derf- I had already purchased the part prior to posting, but your link does verify I got the right one. Thanks so much for that.

02 LW300 - Actually, lucked out and found it earlier today during my lunch break at work. It's on the bottom front of my engine block in the doghouse. Yuck. Super tight and pretty impossible get to without a lift. I don't have one. :/ Looks like I will have to let this normally easy fix on other models I have done be performed by the garage.
Reply With Quote
  #5  
Old 06-12-2017, 11:41 PM
02 LW300's Avatar
Senior Member
 
Join Date: Apr 2015
Location: Willamette Valley, Oregon
Posts: 552
Default

There isn't any coolant below the balance shafts on my Ecotec engines, really just the top of the block and the head. There is a knock sensor, and crank position sensor and an oil pressure sensor low on the front of the block. I have only seen the early Ecotec engines though. Hope this works out for you.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2009 Aura Tail light Problem Jimeeh1970 General Tech Help 3 07-25-2013 10:45 AM
Location of MAP sensor on 2000 SW2? JonWSW2 Saturn S Series Sedan 6 07-04-2010 09:50 PM
2nd coolant temp sensor location found? PdPuNOme Saturn S Series Sedan 5 10-21-2009 09:07 PM
Changing ect sensor hkn royalt Saturn S Series Sedan 1 05-06-2008 10:02 AM
ect sensor redsl1 Saturn S Series Sedan 3 11-08-2005 02:13 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:02 PM.