2007 Vue Hybrid Starting issue

  #1  
Old 01-19-2019, 07:47 AM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 1
Default 2007 Vue Hybrid Starting issue

Battery takes charge however the ignition acts totally dead. All lights work but it just wont turn. Then all the sudden, poor! Fires like there is no issue.

is there a solenoid or fuse I need to look into changing or is it the starter itself?

ps- I cannot find owners manual. I'm frustrated so hoping someone may have the answer. Thanks!
 
  #2  
Old 01-19-2019, 08:03 AM
Rubehayseed's Avatar
Senior Member
Join Date: Jul 2011
Location: Lake Wales, FL
Posts: 3,749
Default

First thing to do is remove both battery cables and clean the clamps and the posts. I suspect you have a corrosion problem. And if you keep having to get the battery charged, it probably needs replacing. Take it to your local auto parts store and have it LOAD TESTED.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Arthur Forgette
Saturn Vue
3
03-25-2018 04:55 PM
metalgod
Saturn Vue
1
07-11-2017 08:33 PM
vuehybrid
Saturn Vue
6
05-27-2015 11:28 AM
BoomerGer
New Member Area
2
04-07-2007 05:50 PM
BoomerGer
General Tech Help
3
03-30-2007 09:04 PM


Thread Tools
Search this Thread
Quick Reply: 2007 Vue Hybrid Starting issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.