Saturn S Series Sedan SL, SL1, and SL2

Request help for my 1999 Saturn SL2 Manual Transmission...

  #1  
Old 05-27-2009, 08:50 PM
Junior Member
Thread Starter
Join Date: May 2009
Location: Red Deer, Alberta, Canada
Posts: 2
Unhappy Request help for my 1999 Saturn SL2 Manual Transmission...

Hi,

Itís nice being in Saturn Community as a new member. Well I own 1999 Manual transmission, Saturn SL-2, 4-Door, 1.9L. Itís also equipped with remote starter and remote control for doors and trunk.
Till yesterday it was ok. 3 days back I forgot to switch off the head lights and the battery power is completely drained. I unscrewed both positive and negative cables from the battery initially and later I fixed it. I boosted the battery afterwards and the engine started ok. I roamed for one day after boosting the battery. However I used to start the engine manually till yesterday and the remote starter and remote control not functioned at all during this period.

Today when I try to switch on the engine manually itís not started and the alarm start honking automatically. Since I donít want to disturb the nibourhood people I cut the horn wires. The battery power is ok now but the engine is not starting? Now Iím concerned about the engine start and remote controls functions (both remote starter and remote control for doors and trunk).

Please find me a solution how to rectify this? First I want to get advice from you guys and if itís not fixed then Iíll take my car to technician. I would appreciate your help. Look forward to hear from you guys.

Thank you,

Regards,

Pubby.
 
  #2  
Old 05-27-2009, 10:07 PM
derf's Avatar
Super Moderator
Join Date: Jul 2005
Location: My Saturn ;)
Posts: 7,695
Default

It will be difficult to troubleshoot without knowing how the remote start was installed/wired.

Did they completely bypass the factory security system (starter disable not withstanding?)
 
  #3  
Old 05-27-2009, 10:43 PM
Junior Member
Thread Starter
Join Date: May 2009
Location: Red Deer, Alberta, Canada
Posts: 2
Default

Yes they did Derf.
 
  #4  
Old 06-07-2009, 02:20 PM
Junior Member
Join Date: Jun 2009
Posts: 7
Default

From the sounds of it, your battery might be shot. Is the battery holding a charge? After it sits, does it have a voltage under 11.5? Also, even though the battery may say it has a charge, it may not have enough amps to start your car. It may turn your accessories on, but it won't start the car.

This usually happens after it has been drained and brought back to life like frankenstein.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SilverCoupe#SC2
SF Help & Suggestion Center
7
09-25-2015 03:03 PM
marka
Saturn S Series Sedan
5
05-28-2015 01:25 AM
crimsonandblue
Saturn L Series Sedans & Wagons
1
04-01-2013 05:09 PM
bob1665
Saturn S Series Sedan
4
02-01-2013 11:56 PM
Bobbed06
Saturn S Series Sedan
9
10-31-2012 09:09 AM


Thread Tools
Search this Thread
Quick Reply: Request help for my 1999 Saturn SL2 Manual Transmission...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.