Starting troubles - Saturn Forum - Saturn Enthusiasts Forums


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-15-2018, 04:41 PM
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 3
Default Starting troubles

i have a 05 ion 1. I recently changed timing chain (did not jump time,guide broke) and now car will not fire at all. It did sit for a year in my garage w/ a dead batter. Car would turn over but not start,even with a generous dose of starting fluid. Now it just clicks like the battery is dead but itís not. Anyone that could point me in the direction of what to do would be greatly appreciated.
Reply With Quote
  #2  
Old 05-15-2018, 06:13 PM
Rubehayseed's Avatar
Senior Member
 
Join Date: Jul 2011
Location: Lake Wales, FL
Posts: 3,432
Default

Yeah, unless you changed the battery, odds are still good that it's a crap battery. If you don't believe me, take it to your closest auto parts store and have them load test it. I'll bet it's no good. You don't say if you replaced it or not.
Reply With Quote
  #3  
Old 05-15-2018, 07:37 PM
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 3
Default

I used the battery from my truck. First 2 tried it turned over but wouldnít start. Third time it clicked as if it was dead,I put it back in my truck and it started. The battery I was using is good

Last edited by Ryan4160005; 05-16-2018 at 07:09 AM.
Reply With Quote
  #4  
Old 05-16-2018, 08:20 AM
Rubehayseed's Avatar
Senior Member
 
Join Date: Jul 2011
Location: Lake Wales, FL
Posts: 3,432
Default

Okay, now you're sharing information. Sometimes corrosion will accumulate under the insulation on your battery cables. Take a good look at them and just try cleaning them with a wire brush in order to get a good clean connection. Check all of your grounds too, as you may have a broken or disconnected one. Are you getting a check engine light or any codes?
Reply With Quote
  #5  
Old 05-16-2018, 08:57 AM
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 3
Default

They are clean of corrosion. Grounds are good. I know 100% itís not the battery or a ground. Messed with it last night and car turned over again but did not start. Turned key in off position,tried again and nothing. Anti theft flashed but then went off. However service engine shows in digital odometer screen. No other lights on in cluster.
Reply With Quote
  #6  
Old 05-16-2018, 10:01 AM
derf's Avatar
Super Moderator
 
Join Date: Jul 2005
Location: My Saturn ;)
Posts: 6,999
Default

Try a 30 min passlock reset procedure. Directions for it are everywhere.

Willing to bet the BCM lost the "password" it is expecting from the passlock sensor in the ignition. If they do not match, the BCM will never tell the ECU to ENABLE the fuel injectors (default state when passlock is active is INHIBIT Fuel Injectors.
Hook up a charger to the ION or leave the truck battery jumped from your car running. You WILL drain a resting battery, rendering the procedure useless, plus you will have a dead truck battery and will have to jump THAT from something else.

If you are getting inconsistent behavior upon cranking, your starter may be suspect.

Have you done a compression test to ensure the timing was set correctly? This would be a straightforward reason for it not firing if it is not building sufficient compression.
Reply With Quote
  #7  
Old 05-18-2018, 12:19 AM
19bonestock88's Avatar
Senior Member
 
Join Date: Feb 2013
Location: Rosedale, WV
Posts: 1,263
Default

Check all the grounds and the connections at the starter... I had an issue back when my Redline ran, that it wouldn’t start. It ended up that one of the grounds had internally corroded and wouldn’t pass enough current to start the car...
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 Saturn Vue Troubles kristen27 Saturn Vue 2 06-28-2009 09:07 AM
94 dohc auto trans troubles paul94sl Saturn S Series Sedan 1 09-15-2008 09:37 AM
Idle troubles after driving butler2 Saturn S Series Sedan 3 02-06-2007 12:33 AM
Rear Defog Troubles.99’Saturn SL2 Angel4Saturn General Tech Help 1 03-10-2006 05:03 PM
EGR Valve troubles gohsthb Saturn S Series Sedan 2 10-12-2005 04:08 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:10 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.