Saturn ion 2 won't start - Saturn Forum - Saturn Enthusiasts Forums

Saturn ion 2 won't start

Reply

 
 
 
  #1  
Old 10-13-2018, 11:29 AM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 8
Default Saturn ion 2 won't start

i have a 2005 saturn ion 2 and it won't start. It does crank. But it will not start. I was running great and then went to start and it won't. We have change ICM and coil pack. Checked battery and it is good. Checked the fuel pump fuse and relay both checked good. Did the check for spark and no spark. Also checked fuel pressure and it is good. Please help
 
Reply With Quote
  #2  
Old 10-13-2018, 01:12 PM
02 LW300's Avatar
Super Moderator
Join Date: Apr 2015
Location: Willamette Valley, Oregon
Posts: 1,118
Default

How many miles? Code check and compression check would be my next steps.
 
Reply With Quote
  #3  
Old 10-13-2018, 02:29 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 8
Default

only has 128000 mile and no codes. compression check good
 
Reply With Quote
  #4  
Old 10-13-2018, 05:43 PM
02 LW300's Avatar
Super Moderator
Join Date: Apr 2015
Location: Willamette Valley, Oregon
Posts: 1,118
Default

What is the compression reading? Bought a 2.2 with a broken chain at 130,000 miles. Just want to make sure we donít miss a step.
 
Reply With Quote
  #5  
Old 10-13-2018, 05:46 PM
02 LW300's Avatar
Super Moderator
Join Date: Apr 2015
Location: Willamette Valley, Oregon
Posts: 1,118
Default

I will have to check my fsm when I get home but there is a ground strap to the valve cover. I donít know if you will get spark without the coil pack screwed to the cover. I have never tried to check for spark on one of these.
 
Reply With Quote
  #6  
Old 10-13-2018, 10:44 PM
02 LW300's Avatar
Super Moderator
Join Date: Apr 2015
Location: Willamette Valley, Oregon
Posts: 1,118
Default

Diagnosing a problem using factory service manual’s charts assumes that you have professional mechanic abilities and training. I can uncomplicate some of it for you.
What does your security light do? If the security light flashes while cranking the bcm is not allowing your engine to start. This is the first of four cranks but won’t start pages.
If the security light is not flashing then we can move on. Next is the crank position sensor, if the pcm does not receive a good signal from the crank sensor both fuel and spark are not enabled.
I will wait to hear back from you.
 
Reply With Quote
  #7  
Old 10-14-2018, 04:57 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 8
Default

Thanks. The security light is like it always was, no flashing. It was missing real bad a while back we changed the coil pack first then the CPS and finally the ICM. I assumed they were good after the ICM fixed the problem and cleared the codes but we left them in place anyway. I still have the original CPS and will put it in next weekend. It seems to have a magnet that closes the contacts and sends a signal to the BCM ?

I wanted to mention the key switch. It was replaced in a recall a couple of years ago. A while after that it would not activate the starter at full throw. After sitting a while it worked fine. This happened about three times and just went away, Two days ago it did it again. It sat a while and would crank but not start. Maybe that's where the troubles are.


Thanks again and we will get back to you next weekend.
 
Reply With Quote
  #8  
Old 10-14-2018, 05:11 PM
02 LW300's Avatar
Super Moderator
Join Date: Apr 2015
Location: Willamette Valley, Oregon
Posts: 1,118
Default

Gm is notorius for ignition switch problems across all product lines. If you have seen these problems before it is entirely possible that this is your problem.
 
Reply With Quote
  #9  
Old 10-14-2018, 07:54 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Posts: 8
Default

I saw a video of a guy changing a key switch module. I was in the bottom part of the steering column. I know it can cause no cranking but can it cause
no start?
 
Reply With Quote
  #10  
Old 10-15-2018, 12:00 AM
02 LW300's Avatar
Super Moderator
Join Date: Apr 2015
Location: Willamette Valley, Oregon
Posts: 1,118
Default

I have had gm pickups loose power to the transmissions and everything else works fine. It has been ignition switch failures in the late 90s. I own a Saturn but have worked on Fords and Internationals since 04.
 
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Saturn ion 2 won't start


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.