service engine soon again!!! - Saturn Forum - Saturn Enthusiasts Forums


New Member Area Are you new?? WELCOME! Check in, tell us about yourself and your ride...

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-20-2006, 05:49 PM
Junior Member
Thread Starter
 
Join Date: Dec 2005
Location: Canada
Posts: 2
Default

My 2001 saturn sl1 is giving me the light and I was reluctant to take it in because it runs fine. I did the plugs and the light went off for about two starts and then back on again. I am wondering if it might be the o2 senser but am at a crossroads here. Pulling codes is only done at a dealership here in Canada so I am a bit miffed by this. The car has only 95000klm on it with the 1.9 litre single overhead . Any leads here would be much appreciated.. Thanks
Reply With Quote
  #2  
Old 03-21-2006, 03:43 PM
Senior Member
 
Join Date: Mar 2006
Location: United States
Posts: 167
Default

Unless you know what code it is you will just as likely waste money throwing parts at it. In my experience however, when the car was running fine and I got a code it has always been an 02 sensor. Now, that being said I have also had low fuel pressure codes come up from bad fuel pumps and the vehicle kept running fine. Plus, I'm not too sure about Saturn, but my Nissan has 4 sensors. It would get very costly to replace them all just on a hunch. You best bet is to get the codes read. If you're close to the US and its worth it to you, you may be able to look up the closest "AutoZone" and they will read the codes for free...
Reply With Quote
  #3  
Old 03-22-2006, 12:11 PM
Junior Member
Thread Starter
 
Join Date: Dec 2005
Location: Canada
Posts: 2
Default

well I talked to the saturn dealer here and they suggested changing the
spark plug wires and it was a given being they only last 100 thousand
klms. I changed them and reset the light and it has not come back
on since. I hope that it was that simple apparantly the wires only last
around 100.000 klm any way its what the dealer was saying.
Reply With Quote
  #4  
Old 03-22-2006, 06:43 PM
Senior Member
 
Join Date: Mar 2006
Location: United States
Posts: 167
Default

Great!!! So that seems to have fixed your problem...
Reply With Quote
  #5  
Old 03-23-2006, 04:36 PM
Senior Member
 
Join Date: Jul 2005
Location: United States
Posts: 153
Default

yah change your wires every 30000 miles
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2002 SL "Service Engine Soon" came on? motmmp247 Saturn S Series Sedan 10 02-07-2008 08:54 AM
service engine soon light tommy7133 Saturn S Series Sedan 2 02-25-2006 12:35 AM
Service Engine Light on mrc209 Saturn 3 Door Coupes 3 10-04-2005 02:47 AM
service engine soon light tommy7133 New Member Area 1 08-16-2005 02:02 PM
service Engine soon Fire_N_Ice New Member Area 2 06-29-2005 01:01 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:04 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.