Dies when you accelerate - Saturn Forum - Saturn Enthusiasts Forums

General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

Dies when you accelerate

Reply

 
 
 
  #1  
Old 01-06-2018, 10:43 PM
Junior Member
Thread Starter
Join Date: Jan 2018
Posts: 1
Default Dies when you accelerate

2000 Saturn sl while driving just looses power bogs downs till you let off the accelerator I've replaced filter and temp sensor any thoughts on what might be the problem and the check engine light does or has not come on
 

Last edited by Darrell Clark; 01-06-2018 at 10:45 PM.
Reply With Quote
  #2  
Old 01-06-2018, 10:51 PM
02 LW300's Avatar
Super Moderator
Join Date: Apr 2015
Location: Willamette Valley, Oregon
Posts: 1,088
Default

I would still check for codes, but if it runs better at light throttle I would suspect a plugged cat converter. Restricted exhaust can be difficult to pinpoint.
 
Reply With Quote
  #3  
Old 01-07-2018, 08:28 AM
Rubehayseed's Avatar
Senior Member
Join Date: Jul 2011
Location: Lake Wales, FL
Posts: 3,572
Default

I agree with Andy. The first thing I'd be checking is the exhaust system for a blockage or the cat or muffler coming apart on the inside.
 
Reply With Quote
  #4  
Old 01-07-2018, 05:10 PM
derf's Avatar
Super Moderator
Join Date: Jul 2005
Location: My Saturn ;)
Posts: 7,358
Default

You can pull the front O2 sensor and attach a back pressure measuring tool. I don't remember the spec but will dig for it if you want me to.
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kzdcz3
Saturn Vue
7
03-16-2014 09:55 AM
andy l200
General Tech Help
1
04-13-2006 03:29 AM
mikes 1994 z28
Saturn L Series Sedans & Wagons
1
03-27-2006 04:47 PM
mellen823
Saturn 3 Door Coupes
1
01-17-2006 01:22 AM
chasemi
General Tech Help
4
12-20-2005 02:43 AM


Thread Tools
Search this Thread