Search
 

Reply
 
 
 
  #1  
Old 06-12-2012, 07:00 PM
ghud46 ghud46 is offline
Junior Member
 
Join Date: Jun 2012
Posts: 3
Default 1994 Saturn SL2 hesitation

I have a 1994 Saturn SL2 sedan with DOHC and close to 200,000 miles. It has recently started acting like it is hesitating while driving at higher speeds and especially while de-celerating. I cleaned the choke assembly to make sure the throttle wasn't sticking. I looked for cracked vacuum hoses etc. The car runs fine if I disconnect the EGR valve vacuum line. The EGR valve appears to be working OK because I can feel the diaphragm move up and down as I accelerate the engine with the vacuum line connected (so I don't think that I have a stuck or malfunctioning EGR valve- I also took the EGR valve off and cleaned out the carbon deposits). Can someone tell me what I should check next because I don't want to run the vehicle with the EGR valve disconnected. Thanks!
Reply With Quote
  #2  
Old 06-12-2012, 11:40 PM
uncljohn's Avatar
uncljohn uncljohn is offline
Senior Member
 
Join Date: Mar 2010
Location: Peoria AZ
Posts: 1,681
Default

I sit here reading your request for help and wonder just exactly I would do in a case like this. I also own a 94 Saturn SC2 coupe as it is. Automatic and more or less in good shape. It has been parked outside most of it’s life. Living in the sun belt the heat and the UV has been brutal to the plastic used on the car. The paint is shot and it now needs some upholstery work. It is a car that if I had to I would feel comfortable driving it across country. My things to do list is to repaint it again and have the upholstery re-done. Why, I like it. Dumb reason ain’t, but what does this have to do with your question?
Cars made about the years of these and representing that level of design actually despite the incredible complexity involved in the design of the things, reliability and operation improvements went from up to twice yearly tune ups (for me anyway based on miles I drive) to not needing any at all. A tune up consisted of replacing worn parts and adjusting the operation of the engine. Many of the parts that wore have been replaced by electronics which don’t wear, adjustments made at tune up time have been replaced by sensors that monitor operation and through the computer controls tune the engine every time it is started. Leaving only pretty much the need to replace the air filter when dirty, the sparkplugs replaced when worn out and they last almost forever in some cases and the odd part when it decays but materials are so much better that is rare for the most part with reasonable car.
But your car is now the same age as mine and that is about 18 years old. That says that some parts are about dead just because they are old.
So what would I do if it were mine and I am rambling and thinking which is why I am rambling.
One weak spot the early S series Saturn had was the heat sensor screwed into the cylinder head at the end on the drivers side.
There are two of them on the 1994. One of them controls the operation of the electric fan. If the engine gets hot enough the fan will turn on. Unless A/C is in use at which time turning on the A/C also turns on the electric fan.
The second sensor is used to monitor engine temperature for the purpose of determining what temperature the engine is running at for the purpose of using things like the choke and the proper air fuel mixture for that operating temperature. It also serves to indicate operating temperature for the heat gauge..
The problems started with the day the car was made. A sensor of the wrong value was used by the factory. What did that do? The same wrong sensor was used for 10 years. This drove aftermarket to stock as a replacement sensor? The one with the wrong value. So for a long time the wrong sensor was installed. What did that do, for the most part nothing, if other conditions were not at some extreme or another. It did however cause the engine to run not quite as it should. Again not really a problem until it became part of another problem. Then the two problems together became hard to diagnose.
The wrong sensor and what ever else is going on at the same time.
duh!
Bringing up to today.
What can that sensor do to you after 18 years maybe? Cause the engine to hiccough and barf. It can be the sole reason or a contributing reason. It has become a known problem covered by now obscure service bulletins and forums such as this which shout out with the slightest provocation, change the sensor. So I will do that now.
Arbitrarily change that sensor AND if the connector appears corroded, replace it too. Where do you find the right one? The after market MIGHT have the right one, there is almost no way to be sure unless you purchase one from a GM dealer. In my area a local Chevrolet dealer advertises Saturn service and will order parts. See if you have a local GM dealer that will get it for you. It is the one with the most wires on your car. located at the end of the cylinder head on the drivers side.
Dang, that was a long way around but it is incredible the amount of problems this dang sensor has been a contributing factor for.
O.K, 18 years old. I see a lot of people talking about cleaning carbon out of the bits and pieces on the Intake manifold. The throttle body, egr and maybe other things. Mine has not suffered from it yet but many comments are made. Vacuum lines rotting. Good point to check. 18 year old rubber is generally yucky.
Spark plug wires. After 18 years they are questionable. At least look at them and see if it looks like the rubber is flexible and any good. If they are not replace them.
Check the spark plugs to see if they are corroded. This car was not designed to use the platinum plugs and it is a little strange, if used the sensing circuit for the spark detecting will malfunction and cause false error codes and check engine lights. Replace them if corroded. What kind? The factory has a recommendation and others here do to. I myself use Champion just because I like them and they give me no problems. I use them in my high performance race engines and my Saturn. See if the air filter is dirty.
If so put a new one on.
Even with 200,000 miles on it, the design is good, if general maintenance is kept up it should run fine. The carbon build up is a bit weird and the impact of the sensor is out of the ordinary.
Past that if everything else is o.k. the things should run reliably .
I can not think of anything past those items that should have any major impact. I would suggest using something like a 10w40 oil during the summer and something like a 10w30 during the winter. I myself use a 20w50 oil in mine.
I wish I had something magic to say, hope this helps and have a nice day.
Reply With Quote
  #3  
Old 06-14-2012, 05:27 PM
ghud46 ghud46 is offline
Junior Member
 
Join Date: Jun 2012
Posts: 3
Default Thanks for your help!

uncljohn- Thanks for your reply and help. I will find a new sensor and see if replacing it fixes the problem. I like my Saturn even though it is so old. I especially like the way it handles and shifts (5 speed) compared to other cars. I will keep driving it until it's shot!
Click the image to open in full size.
Reply With Quote
  #4  
Old 06-14-2012, 06:02 PM
sw2cam's Avatar
sw2cam sw2cam is offline
Super Moderator
 
Join Date: Mar 2006
Location: Arizona
Posts: 3,154
Default

How long have you had the SATURN ?
__________________
INACTIVE ACCOUNTS ARE SHUT DOWN. START POSTING!

Joe: Arizona
2007 Quad Cpe 2.4L manual
White w/tan leather
Appearance, Enhanced performance, and Travel pkg
Reply With Quote
  #5  
Old 06-14-2012, 07:41 PM
ghud46 ghud46 is offline
Junior Member
 
Join Date: Jun 2012
Posts: 3
Default

I have had the car since 2002 (bought it used with 46,000 miles on it). The odometer quit working 4 years ago and it had 144,000 miles at that time. I put an average of 15-20,000 miles on it each year.

I was looking online for the sensor that uncljohn mentioned and I found one called a "Air Charge Temperature Sensor" Can someone confirm that this sensor is the one that I should try to replace as per uncljohn? Here is a link to it online:

http://www.carpartsdiscount.com/auto...ml?3593=319474

Thanks.
Reply With Quote
  #6  
Old 06-14-2012, 09:09 PM
derf's Avatar
derf derf is offline
Super Moderator
 
Join Date: Jul 2005
Location: Out on the Tiles
Posts: 3,266
Default

Did you clean out the EGR ports where it attaches?

Neither of the egrs on my mid 90's coupes made it to 200k without being replaced.....I had already tried cleaning them (yet again) but there came a point where it didn't help anymore, The issues on decel are indeed indicative of an egr issue. You may need to bite the bullet and buy one unless you have access to test equipment for testing yours.

Any stored codes?
__________________
I bet you think I'm doin' this all for my health
I shoulda looked again babe at somebody else
Feelin' like I've done way more than wrong
Feelin' like I'm livin' inside of this song
Feelin' like I'm just too tired to care
Feelin' like I've done more than my share
Could it be the way I've carried on
Like a broken record for so long.......

___________________
derf/Wash PA
95 SC2 ~232K
97 SC2 ~244K
'14 Ford Escape SE 2.0L ~9k

Last edited by derf; 06-15-2012 at 07:38 AM. Reason: removed wrongness
Reply With Quote
  #7  
Old 06-14-2012, 11:19 PM
uncljohn's Avatar
uncljohn uncljohn is offline
Senior Member
 
Join Date: Mar 2010
Location: Peoria AZ
Posts: 1,681
Default

Looking at the picture and the description and with out going out to compare it to mine it looks like the right one. And $8.00 plus shipping is a lot better deal than buying from a dealer.
But be aware, that sensor has a history that is not a good one. They came from the factory incorrect for many years before it was picked up on that when they drift as to their value they can cause some really crappy running problems and are the direct reason for the problems.
Aftermarket never seemed to get the correct sensor in stock as far as it can be determined.
Thus to avoid potential problems and they are real to be sure it is suggested you purchase one from a dealer, keeping in mind there are none but some GM dealers have and will order them. That is done to insure that you actually have the correct part for proper operation. This was called out in a service bulletin some where around the year 2000 or so. It was in play for a long time.
We hobbyists are going to have to accept that at some point in time GM is going to stop carrying parts and we will then have no choice but to get them where we can or learn how to recognize an out of tolerance part. It is suggested that if the connector is damaged it be replaced also, as far as I know that is only available from a dealer some where. For $8.00 I would gamble it would work, but if the heat gauge starts running high and engine performance goes down the toilet, you bought the wrong one.
Reply With Quote
  #8  
Old 06-15-2012, 07:38 AM
derf's Avatar
derf derf is offline
Super Moderator
 
Join Date: Jul 2005
Location: Out on the Tiles
Posts: 3,266
Default

sorry right "part" (air temp and ECTS are identical) -- I should learn to read
still would get from dealer along with connector if you replace.
__________________
I bet you think I'm doin' this all for my health
I shoulda looked again babe at somebody else
Feelin' like I've done way more than wrong
Feelin' like I'm livin' inside of this song
Feelin' like I'm just too tired to care
Feelin' like I've done more than my share
Could it be the way I've carried on
Like a broken record for so long.......

___________________
derf/Wash PA
95 SC2 ~232K
97 SC2 ~244K
'14 Ford Escape SE 2.0L ~9k
Reply With Quote
Old 06-15-2012, 07:38 AM
 
 
 
Reply

Tags
1994, car, diagram, disconnected, egr, enthusiasts, hesitation, jumps, line, run, saturn, sc2, sl, sl2, vacuum


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Auto Parts

- Exhaust
- Bike Carriers
- Car Vacuums
- Hidden Hitch
- Hitch Covers
- Dash Kits