Search
 

Reply
 
 
 
  #1  
Old 12-19-2009, 12:21 AM
Jmrothrock29 Jmrothrock29 is offline
Junior Member
 
Join Date: Dec 2009
Posts: 7
Default Saturn Sl2 Auto Transmission Rough shift

I have a 2002 saturn sl2 that i just replaced the vavle body on The Transmission The Problem I am Having is That now with the Remanufactered vavle body installed it shifts rough under hard acelleration wich it was not doing before installing this vavle body wondering what you people might think the problem might be now i'm keeping my fingers crossed i am not looking at a full rebuild



Just For some info The problem i was having before Replacing the vavle body Was when going up a hill it would jerk out of of overdirve and do the same if you manualy take it out of overdrive it would do the same bwetween second and third gear. I Had a tranny shop look at it and they said it was Most comon for the vavle body to be causing this. The trans is no longer having this symptom.

Hope this is not too lengthy i'm new to these forums thks

Last edited by Jmrothrock29; 12-19-2009 at 12:30 AM.
Reply With Quote
  #2  
Old 12-19-2009, 07:51 AM
hoseppi's Avatar
hoseppi hoseppi is offline
Senior Member
 
Join Date: Jan 2009
Location: Annapolis Md.
Posts: 270
Default

How long has the new valve body been in the car? After the installation of a valve body, the car has to go through a learning process.I put a used valve body in a 2001 SL2. Initial test drive indicated no change, but subsequent road trip cleared up all problems. It now runs like a new car
Reply With Quote
  #3  
Old 12-19-2009, 08:29 AM
Jmrothrock29 Jmrothrock29 is offline
Junior Member
 
Join Date: Dec 2009
Posts: 7
Default

I Have put a couple hundred miles on since it was installed so far and am goign to put a couple hundred on again today. The miles have been combination in town highway
Reply With Quote
  #4  
Old 12-19-2009, 08:45 PM
Jmrothrock29 Jmrothrock29 is offline
Junior Member
 
Join Date: Dec 2009
Posts: 7
Default

I drove another hundred and fifty miles today combination in town highway again i also checked the computer for codes with scan tool none showed reset computer anyway to see if it helped still seems to be shifiting rough though so in the am i am going to take apart the pan again and ohm all the sylynoids to see if any of them are below spec acording to what i have found they should be at 4.5 ohm's this morning i ohm'ed out the sylynoids from my old vavle body all were at 4.2 ohm's so if i find any below that i will put my sylonoids from my old vavle body in and retest
Reply With Quote
  #5  
Old 12-19-2009, 09:19 PM
hoseppi's Avatar
hoseppi hoseppi is offline
Senior Member
 
Join Date: Jan 2009
Location: Annapolis Md.
Posts: 270
Default

Sorry, I must have fogotten to send my last response, so I will do it now. That transmission has reached its point of diminishing returns, as far as the learning process goes. That normally would be a 50 to 90 mile process. It is possible that the rebuilt valve body is defective since you stated this symptom did not exist before. That is why I like used, low mileage valve bodies (nobody puts these things together better than the manufacturer). I have a retirement village for wrecked Saturns so I have access to plenty of used parts.Current weather conditions on the East Coast indicate more inventory arriving in the near future.
Reply With Quote
  #6  
Old 12-20-2009, 08:51 AM
Jmrothrock29 Jmrothrock29 is offline
Junior Member
 
Join Date: Dec 2009
Posts: 7
Default

Ok i Cant seem to Get good reading with the vavle body in the car to cheeck all the sylnoids so I am goign to take it back out today and check all the sylnoid here is Why I'm Not 2 Woried about finding i also have 2 aditionale rebult vavle body 2 From The same guy and one from Another i check the ohm's on the other vavle body from the 1st guy and found that one of the sylnoids are at 2.5 ohm's Bad So i am suspecting the same in the first to find at least one bad sylnoid in the first vavle body The vavle body from the third guy all slynoids ohm in the 4.5 to 4.8 range so i think i am goign to try that vavle body and see what happens. Hate the fact i have to do it twice but oh well
Reply With Quote
  #7  
Old 12-20-2009, 12:33 PM
derf's Avatar
derf derf is offline
Super Moderator
 
Join Date: Jul 2005
Location: Out on the Tiles
Posts: 3,320
Default

quite a collection of valve bodies -- funny how some dudes call them rebuilt but don't check the basic stuff
Reply With Quote
  #8  
Old 12-20-2009, 11:31 PM
Jmrothrock29 Jmrothrock29 is offline
Junior Member
 
Join Date: Dec 2009
Posts: 7
Default

Ok Installed the other vavle body and tha car shifts perfect whew am i glad of that i just dont have the money for a rebuild Right now even though i know it wont be long with 176K On this trans I'm hoping to get at least another 30 K Or more out of this tranny So i will dirve for work all day tomorow and see how things work. Kepping my fingers crossed. I have a trip to tucson next month and need this car to be working good. Thanks for all who answered my questions I will post another upadat in couple days after i put some mile's on it
Reply With Quote
Old 12-20-2009, 11:31 PM
 
 
 
Reply

Tags
01, 2002, auto, body, hard, l300, problems, rough, saturn, shift, shifting, shifts, sl2, transmission, valve, wont


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Auto Parts

- Exhaust
- Bike Carriers
- Car Vacuums
- Hidden Hitch
- Hitch Covers
- Dash Kits