Reply
 
 
 
  #1  
Old 12-02-2005, 08:58 PM
pitar pitar is offline
Junior Member
 
Join Date: Dec 2005
Location: United States
Posts: 5
Default



hey people! I recently bought 2002 saturn sl1, 102k miles, 5 speed manual trans. I am having problems with rpm's because they never go lower than 1200. Check engine light is on, code p0507->Idle Air Control System RPM Higher Than Expected. I tried cleaning the throttle body but it only made it worse because now rpm's are not going lower than 1500. I Anyone experienced something similar? Any help would be appreciated!
Reply With Quote
  #2  
Old 12-06-2005, 01:45 AM
Skid2 Skid2 is offline
Junior Member
 
Join Date: Nov 2005
Location: United States
Posts: 12
Default

You should check for a vacuum leak first, then remove and clean the idle air control valve and the seat where it screws in.

Generally a high idle is an indication of a severe vacuum leak around
the intake manifold, throttle body, or egr system. When you took it
apart you may have disturbed the part that was leaking and made it
worse. Also check the brake booster and PCV system for leaks. If you
can't find any vacuum leaks then remove the IAC and clean the seat and
valve.
Reply With Quote
  #3  
Old 12-06-2005, 11:55 AM
pitar pitar is offline
Junior Member
 
Join Date: Dec 2005
Location: United States
Posts: 5
Default



Hi and thanks for reply!


I already replaced IAC with the new one from dealer, it didnt help. I couldnt find any vacuum leaks anywhere, aroundegr or throttle body. I forgot to mention that I am also getting code p0301- misfire on cylinder #1. I replaced spark plugs, wires and both ignition modules (all these parts were due anyway) but this code is still on along with the p0507 from before. I think I will just have to bring it to a dealer, I am out of ideas[img]smileys/smiley6.gif[/img]
Reply With Quote
  #4  
Old 12-10-2005, 10:50 AM
snnave snnave is offline
Junior Member
 
Join Date: Dec 2005
Location: United States
Posts: 3
Default

Any luck with your problem? I too have an 02SL1 with the exact codes, PO301 and PO507. I have heard that this vehicle has a problem with a leaky intake manifold gasket. Any help would be great. Does this problem usually cause your gas mileage to decrease?
Reply With Quote
  #5  
Old 12-10-2005, 12:52 PM
pitar pitar is offline
Junior Member
 
Join Date: Dec 2005
Location: United States
Posts: 5
Default

Yes, you are right. After I ran out of ideas I took it to a local delaer and they diagnosed it with bad intake manifold gasket. They estimated parts and labor to be around $590 but I just paid them for diagnostics and took the car to my mechanic who did everything for $200. Intake manifold gasket (from dealer) costs only $12, labor is about 3 hours and there you go. It runs great now, no more codes, no high rpm's. Good luck!
Reply With Quote
  #6  
Old 12-10-2005, 01:05 PM
Skid2 Skid2 is offline
Junior Member
 
Join Date: Nov 2005
Location: United States
Posts: 12
Default

Not to say I told you so but......the most common problem that causes
the symptoms you described is VACUUM LEAK. Usually leaks around the
intake manifold or EGR system are a little hard to find. Sometimes you
can have an internal vacuum leak in a V configuration engine that
causes the same problem.

Normally you can repair this problem yourself for the cost of a gasket
set as long as you have a little mechanical ability and some patience.
I've done a lot of them on different cars. I have never done a Saturn
but judging from how easy other things are on these cars it can't be
that hard.



Don


Reply With Quote
  #7  
Old 12-10-2005, 05:28 PM
snnave snnave is offline
Junior Member
 
Join Date: Dec 2005
Location: United States
Posts: 3
Default



Thanks guys,


I sprayed a little carb and choke cleaner right at the #1 intake and it surged and all most stalled the engine.
Reply With Quote
  #8  
Old 12-10-2005, 05:30 PM
snnave snnave is offline
Junior Member
 
Join Date: Dec 2005
Location: United States
Posts: 3
Default

Does anybody know the torque value and pattern for the intake manifold on the SL1 1.9L? Should an RTV be added to the gasket to prevent any future leaks?
Reply With Quote
  #9  
Old 12-10-2005, 11:50 PM
Skid2 Skid2 is offline
Junior Member
 
Join Date: Nov 2005
Location: United States
Posts: 12
Default

Quote:
Originally Posted by snnave
Does anybody know the torque value and pattern for the
intake manifold on the SL1 1.9L? Should an RTV be added to the
gasket to prevent any future leaks?


TBI models = 188 in/lbs, MPFI models through 99 = 22 ft/lbs according
to my manual. They don't give a torquing sequence. Usually the gasket
manufacturer will recommend RTV if needed. I usually use gasket-tack on
paper gaskets and nothing on cork or rubber.

Reply With Quote
  #10  
Old 12-11-2005, 07:36 PM
myjawjeep myjawjeep is offline
Junior Member
 
Join Date: Dec 2005
Location: United States
Posts: 1
Default



I just purchased a 2002 SL-1, 36000 Miles. Soon after I got this car the SES lighe came on. At first it would come on ,then go off now it stays on. I took it to a dealer, they stated that it indicated thatb Fuel to Rich. They had it 2 days and I was told that they had discussed this problem With the Factory, They tried several different solutions, however nothing so far corrected the problem. Light still on!


The car is running great, and my milage is 40 mpg on the highway.


Would appreciate any suggestion.
Reply With Quote
Old 12-11-2005, 07:36 PM
 
 
 
Reply

Tags
01, 2000, 507, body, cleaned, code, high, iac, idle, ion, p0507, po507, replaced, rpm, saturn, sl1, throttle


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Auto Parts

- Exhaust
- Bike Carriers
- Car Vacuums
- Hidden Hitch
- Hitch Covers
- Dash Kits