Search
 

Reply
 
 
 
  #1  
Old 01-27-2006, 02:01 AM
Junior Member
 
Join Date: Jan 2006
Location: United States
Posts: 3
Default



I just flushed the coolant and replaced the thermostat in 97 sc1. It was stuck open. Now the Temp/Coolant Level idiot light will not stop flashing. The T-stat is working, and the fan cycles o.k., temp indication is o.k. Isthe idiot light controlled by anothersensor somewhere? My repair manual has disappeared and the wife is driving me crazy. HELP!


dON
Reply With Quote
  #2  
Old 01-31-2006, 11:16 PM
Junior Member
 
Join Date: Jan 2006
Location: United States
Posts: 3
Default

O.k., I figured it out with some help from a previous post. I needed to replace the coolant temp sensor, located on the drivers side of the head,AND dismantle and clean the connection. The connection must be pinched to remove from the sensor or you will tear the wires out like I did! Duh. Check out the sensorat the front of the air intake tubeto see the same type of connection.
Reply With Quote
 
 
 
Reply

Tags
06, 96, blinking, coolant, flashes, flashing, heat, idiot, l300, light, lights, panel, saturn, temp, temperature, vue


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Auto Parts

- Exhaust
- Bike Carriers
- Car Vacuums
- Hidden Hitch
- Hitch Covers
- Dash Kits